Air Gun Forums
Home | About Us | Contact Us
Quick Member Login:
Forgot password?
Forum Sponsors:
Left Advertisement

becomeasponsor
Forum Statistics:
Forum Members:
Total Threads:
Total Posts:


There are users
currently browsing forums.
You don't appear to be registered. Click here to register
Search the forums:
Old 01-02-2017, 03:38 PM   #1
Mccaw64
Junior Member
 
Join Date: Nov 2016
Posts: 2
Default no pressure...

Recently acquired a old daisy 840 single pump, it functions fine,but it does not have the pressure it should. I've watched all the you tube videos,and it seems that the o- ring on the plunger is the only thing that seals the pressure chamber, is it time for a new o ring?? It doesn't seem to be that difficult to tear down and replace. Ideas? Opinions?
Mccaw64 is offline   Reply With Quote
Old 01-09-2017, 01:42 AM   #2
Clifford
Member
 
Join Date: Oct 2012
Posts: 85
Default

Never taken one apart but the likely culprit would be one of the seals. If you take it apart it should become more obvious which one is bad.
Clifford is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:11 PM.
Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Copyright 2011 Airgunforums.org, All Rights Reserved